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DameWare Mini Remote Control is a lightweight remote control intended primarily for 
administrators and help desks for quick and easy deployment without external dependencies 
and machine reboot. Developed specifically for the 32 bit Windows environment (Windows 
95/98/Me/NT/2000), DameWare Mini Remote Control is capable of using the Windows 
challenge/response authentication and is able to be run both as an application and a service. 
Some additional features include View Only, Cursor control, Remote Clipboard, Performance 
Settings, Inactivity control, TCP only, Service Installation and Ping. 
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1. Menu – Client 
 
1.1 File 
 
1.2 Connect 
When the Connect… item is selected from the File menu or the Connect icon is selected from 
the toolbar, a Remote Connect dialog box is displayed which will allow you to enter 
information needed to connect to the remote machine. You will then be able to fill in the 
Machine Name, User Name, and Password and may optionally add the Domain Name of the 
computer to which you wish to connect to remotely.  
 
The following are options available to you from this dialog. 
 
Use Current Logon Credentials. This option, when checked, allows you to use the security 
credentials of the currently logged on user. Remember Security Credentials. This option, 
when checked, remembers the security credentials entered and will redisplay them upon 
reconnection.  
 
Cancel Upon selection will cancel the Connect option. 
 
Delete Entry Deletes the current remote connection entry. 
 
Properties… See Property Sheet dialog view 
 
1.3 Disconnect 
Selecting this option from the File menu or the Connect icon on the toolbar disconnects the 
connection between the local and remote machine. 
 
1.4 Install Service 
This functionality is only available on Windows NT or Windows 2000. To install the service, 
select the Install Service item from the File menu. The Server (Service) Installation dialog will 
be displayed in which you must enter either the Machine Name or IP Address of the machine 
on which DameWare MRC is to be installed. 
 
1.5 Remove Service 
This functionality is only available on Windows NT or Windows 2000. To remove the service, 
select the Remove Service item from the File menu. The Server (Service) Removal dialog will 
be displayed in which you must enter either the Machine Name or IP Address of the machine 
from which DameWare MRC is to be removed. 
 



1.6 Print...Ctrl+P (file) 
The Print option displays a dialog box where you may make changes to the default printer 
settings. 
 
1.7 Print Preview 
Upon selection of the Print Preview option on the File menu or by selecting the Print Preview 
icon on the toolbar, you may view the requested data to be printed. 
 
1.8 Print Setup... 
When the Print Setup option is chosen from the File menu a standard Windows Print Setup 
dialog box is displayed consisting of several customizable options for you to choose for your 
printing requests. 
 
1.9 Exit 
Selecting the Exit option from the File menu will allow you to exit DameWare Mini Remote 
Control 
 
 
2.0 Send 
 
2.1 Send Ctrl+Alt+Delete 
This option is only functional with Windows NT and Windows 2000. Upon selection of this 
option from the Send menu or by selecting the icon from the toolbar, DameWare Mini Remote 
Control sends the Ctrl+Alt+Delete keystrokes to the remote machine and if accepted, the 
Windows NT logon/logoff dialog box will be displayed. 
 
2.2 Send Ctrl+Shift+Escape (Task Manager) 
This option is functional only with Windows NT and Windows 2000. Selecting this option from 
the Send menu will send the Ctrl+Shift+Escape keystrokes to the remote machine and if 
accepted, will display the Windows NT Task Manager on the remote machine. 
 
2.3 Send Ctrl+Escape (Start Menu) 
This option is functional with Windows 95/98/Me and Windows NT 4.0 with Service Pack 2 
and below. Selecting this option from the Send menu or the toolbar sends the Ctrl+Escape 
keystrokes to the remote machine and if accepted, will display the Start Menu of the remote 
machine. 
 
2.4 Send Alt+Tab (Switch) 
Depressing the Alt key along with the Tab key sends the Alt+Tab keystrokes to the remote 
machine and if accepted, allows you to switch between programs that are running on the 
remote computer. 
 
 
3 View 
 
3.1 Full Screen 
A full screen of the remote machine is displayed whenever the Full Screen option is enabled 
from the View menu. To return to the default screen size, simply disable the Full Screen 
option in the View menu. This function may also be accomplished by selecting the Full 



Screen icon on the toolbar. To return to the default screen size, click once more on the same 
icon on the toolbar. 
 
3.2 View Only 
The View Only option, when selected from the View menu or by selecting the View Only icon 
from the toolbar, allows you to only view the activities of the remote computer. 
 
3.3 Use Windows Hot Keys 
Within DameWare Mini Remote Control, whenever the Use Windows Hot Keys option is 
enabled in the View menu, you will be capable of implementing three of the Windows Hot 
Keys. These hot keys are: 
 
Alt + Tab When these keys are depressed, you can switch between programs that are 
running. 
 
Ctrl + Escape When these keys are depressed, the Windows Start menu is presented. 
 
Windows Key The Windows Start menu of the remote machine is presented whenever the 
Windows key on the keyboard is depressed. 
 
This option is also available by clicking on the Enable/Disable Windows Hot Keys icon on the 
toolbar. 
 
Note: This option is available for Windows NT, Service Pack 3 or greater and Windows 
2000. 
 
3.4 Show Local Cursor as Dot 
You will be allowed to choose whether to display the local cursor as a dot instead of the 
default, which is most commonly an arrow, upon enabling the Show Local Cursor as Dot 
within the View menu or by selecting the icon on the toolbar. 
 
3.5 Show Remote Cursor 
Enable or disable the Show Remote Cursor option from the View menu or select the icon 
from the toolbar to choose whether or not to show the remote cursor 
 
3.6. Warning Border 
When enabled from the View menu, this option displays the warning border around the 
remote machine’s screen. This provides you with the distinction of screens for easier 
recognition and can be disabled at your discretion by disabling the option in the menu. You 
may also enable or disable this border by clicking on the Warning Border Icon on the toolbar. 
 
3.7. Properties... 
The DameWare Mini Remote Control Property Sheet dialog box presents you with may 
customizable options allowing you to set the program properties to your specifications. You 
may choose from the following available options. 
 
- Remote Options 
 
The options within the Remote Options tabbed dialog, allow you to choose the way in which 
you view and manage the remote machine. The View Only option, when checked will allow 



you to only view the activity of the remote. The Show Remote Cursor box when checked 
allows you to see the activity of the remote cursor. And the Enable Remote Clipboard box, 
when checked, will automatically transfer the contents of the local machine’s clipboard to the 
remote and vice versa when text is placed in the clipboard. Only text format is supported. 
 
The Scan Blocks (Scan Lines/Blocks) option and the Delay Between Scan Block Update 
work conjunctively to determine the most efficient method of screen transfer while conserving 
system resources. 
 
The Port Number for the local machine and the remote machine should be the same. 
 
- Local Options 
 
When the Show Local Cursor As A Dot option is enabled, the cursor of the remote machine is 
indicated by a dot allowing the remote cursor to dominate. The Warning Border on Connect 
option allows you to display the remote screen with a warning border, which aids in the 
recognition between the local and remote screen. This option can be enabled or disabled at 
your discretion. The Full Screen Tool Bar option gives you the flexibility in showing either All 
Buttons of the toolbar or only the Full Screen Button. Either of these can be easily relocated 
on the screen by simply using drag and drop. The Print option of the Local Options tabbed 
dialog consists of the selection, Keep Aspect. You may choose how you wish to print data 
from the remote machine. 
 
- Inactivity Options 
The options in the Inactivity Options tabbed dialog allow you to control the actions of the 
remote computer. By checking the Enable Sleep on Inactivity box, you are presented with the 
option to set, in minutes, the length of time the client portion of the service must be inactive 
before the server portion of the service sleeps. The server will then sleep, or remain inactive, 
until it receives a wake up call. Within this tabbed dialog, you are also able to choose to 
disconnect the service within the number of minutes of inactivity specified by you. 
 
- Display Options 
The last option within the Property Sheet dialog will give you the option to choose the color 
depth of the remote machine. It provides for a Remote Default Display option, which will 
display on the local machine the actual display of the remote computer. There are other 
options available to choose as well. 
 
 
4 Help 
 
4.1 Help Topics 
The DameWare Mini Remote Control help file will be displayed whenever this option is 
chosen. 
 
4.2 Registration... 
In order to register DameWare Mini Remote Control, you may purchase the program from 
DameWare Development. Upon purchase of the program, you will be sent a registration 
number which, when entered into the Registration box, will allow you licensed use of 
DameWare MRC. To invoke the Registration box, from the Help menu select Registration… 
then click on the Registration button on the About box that is displayed. A Registration dialog 



box will be presented and you will then be able to fill in the fields with the requested 
information along with the registration number supplied to you by DameWare Development. 
This process may also be accomplished by selecting the About DameWare MRC icon on the 
toolbar. 
 
4.3 About DameWare MRC 
When you select the About DameWare MRC item from the Help menu or the icon from the 
toolbar, you will be presented with information regarding DameWare Development and the 
DameWare Mini Remote Control. This dialog box offers an option for registration of the 
program as well. 
 
 
5. Menus server 
 
5.1 DameWare Mini remote Control 
DameWare Mini Remote Control Server 
 
When the DameWare Mini Remote Control Server is installed, an icon will appear in the 
System Tray. When connected, this icon will be animated. When you click the right mouse 
button on the Server icon, a dialog is displayed from which you may utilize any of the 
following options. Who Is Connected… Selection of this option will display the MRC 
Notification dialog in which you are shown such information as the User ID, Logged on As (if 
this is not the same as the User ID) and From, which is the name of the remote machine. The 
display will disappear whenever you click the mouse within the box or after a short length of 
time. 
 
Disconnect… When selected, a dialog is displayed asking you if you wish to disconnect the 
connected user(s). 
 
Settings… Selecting the Settings… item from the menu will display the DameWare 
Mini Remote Control Server Setup dialog box, which allows you to choose the method of 
authentication you prefer. When the Use Windows NT Challenge/Response box is enabled, 
DMRC will use the standard Windows NT Challenge/Response method of authentication. If 
disabled, you must then enter the User ID, Password and then Confirm Password at which 
time DMRC will perform its’ proprietary method of Challenge/Response authentication. The 
Notify on Connection box can be enabled/disabled by checking or un-checking the box. The 
Default button, when selected, will change the setting options to the default setting. 
 
About… When this item is selected from the menu, a dialog is presented with information 
about DameWare Mini Remote Control. 
 
Exit Upon selection, you will then exit DMRC. This option is only available when running as 
an application. 
 
 



6. General information 
 
6.1 System Requirements 
The minimum system requirements for DameWare Mini Remote Control are Windows 95 or 
greater (this includes Windows 98 and Windows Me) and Windows NT 4.0 or greater (this 
includes Windows 2000).  
 
Your video card must support the following raster capabilities: 
· Capable of transferring bitmaps (RC_BITBLT) 
· Capable of supporting the Windows APIs, SetDIBits and GetDIBits functions 
(RC_DI_BITMAP) 
· Must support more than one color plane. 
 
DameWare Mini Remote Control supports only TCP Protocol. 
 
6.2 Performance 
Unfortunately, one of a remote control’s strongest features is not speed! As Video adapters 
are rapidly improving and increasing the number of colors and resolution the performance of 
remote controls decrease. DameWare Mini Remote Control compresses all data sent back 
and forth. This compression is hampered by the complexity of the desktop and can drastically 
affect the performance. The major performance players are: CPU, connection speed, and 
video cards. DameWare Mini Remote Control offers sufficient settings to obtain a reasonable 
performance in almost any situation. Those performance settings are: Scan Blocks, Delay 
between Scan Blocks, Display Options and Compression Level. 
 
6.3 Security 
For security reasons, DameWare Mini Remote Control uses the Windows NT 
challenge/response by default. For Windows 95/98/Me, this option is only possible if they are 
running in user-level security and not in share-level security. In this case, you must uncheck 
the box for Windows NT challenge/response on the DMRC server configuration.  
 
In some countries/corporations, it may be expressly forbidden to connect to a client’s 
workstation without the remote users’ permission. DameWare Mini Remote Control is 
capable of accommodating this requirement by placing the file in either the directory that 
DWRCS.EXE is running or in the system directory (system32 on NT/2000) and adding the 
following entry. 
 
Filename: DWRCS.INI 
Section: [Settings] 
Key: Permission Required 
Value: Yes or No 
 
Sample: 
[Settings] 
Permission Required=Yes 
 
When this is implemented, the client will display a dialog in which the remote user can either 
accept or decline the connection. The default setting in DMRC does not implement this 
restriction. You must manually install the above file to activate this functionality. Without this 
file, the client will continue to have the capability to turn on connection notification that will 



display a dialog box showing the remote users’ ID and machine or he can also disconnect 
any connections. 
 
Sample of all available settings: 
[Settings] 
Requires the local users to accept the connection - No is default 
Permission Required=Yes 
Permission Required=No 
 
Notify On New Connection - Yes is default 
Notify On New Connection=Yes 
Notify On New Connection=No 
 
Show SysTray Icon - Yes is default 
Show SysTray Icon=Yes 
Show SysTray Icon=No 
 
Enable Add Client Connection Menu - Yes is default 
Enable Add Client Connection Menu=Yes 
Enable Add Client Connection Menu=No 
Enable Disconnection Menu - Yes is default 
Enable Disconnection Menu=Yes 
Enable Disconnection Menu=No 
 
On Disconnect Logoff Desktop - No is default 
On Disconnect Logoff Desktop=Yes 
On Disconnect Logoff Desktop=No 
 
"Force Applications Close" is used in conjunction with "On Disconnect Logoff Desktop" 
Force Applications Close - No is default 
Force Applications Close=Yes 
Force Applications Close=No 
On Disconnect Lock Workstation 
For Windows 2000 only 
On Disconnect Lock Workstation=Yes 
On Disconnect Lock Workstation=No 
 
Logon At Logon Desktop Only 
For Windows NT/2000 only 
Logon At Logon Desktop Only=Yes 
Logon At Logon Desktop Only=No 
 
Port - 6129 is default 
Port=6129 
 
The connection for all account types other than Administrators require that the system be at 
the Logon Desktop unless you select the following option. Then the user can connect if the 
local user accepted the connection request. 
 
Permission Required for non Admin - No is default 



Permission Required for non Admin=Yes 
Permission Required for non Admin=No 
 
The DWRCS.INI file must be placed in the system directory. 
On Windows 95/98/Me, the system directory would most commonly be: C:\Windows\system 
On Windows NT/2000, the system directory would be: systemroot\system32 
 
6.4 Service Installation 
For Windows 95/98/Me, there is no functionality for doing a remote installation of the server 
portion of the remote control. You must manually install the server service using the following 
command line "DWRCS.exe -install". This would install the server as a service. You can also 
run the server as an application simply by executing the DWRCS.exe but when the computer 
is rebooted or if the user exits the application, the server would not be available. To remove 
the service use the following command line "DWRCS.exe -remove", then reboot the 
computer. 
 
For information on mass deployment of the Mini Remote Control client agent check our web 
site www.dameware.com or contact DameWare Technical support at  
Support@dameware.com. 
 
 
7 DameWare Mini Remote Control Information 
 
7.1 Acknowledgements and References 
Copyright Acknowledgement 
Copyright© 1990-2000 DameWare Development All rights reserved. 
Portions of this product are Copyrighted© 1991-2000 by Microsoft Corporation. All rights are 
reserved. All Microsoft Corporation disclaimers apply. 
 
Trademarks 
DameWare Mini Remote Control© is a trademark of DameWare Development. 
Microsoft® Windows Terminal Server® is a registered trademark of Microsoft Corporation. 
Microsoft® Windows® is a registered trademark of Microsoft Corporation. 
Microsoft® Windows NT Server® is a registered trademark of Microsoft Corporation. 
Microsoft® Windows 2000 Server® is a registered trademark of Microsoft Corporation. 
Microsoft® Windows NT Workstation® is a registered trademark of Microsoft Corporation. 
Microsoft® Windows 2000 Workstation® is a registered trademark of Microsoft Corporation. 
 
7.2 Registration Information 
The evaluation release of DameWare Mini Remote Control is fully functional, however after 
fifteen days of usage you will encounter a ‘nag’ screen. You will then have the remaining 
fifteen days of the thirty-day evaluation period to register the program without interruption. 
Upon receipt of your purchase of DameWare Mini Remote Control, you will receive a 
registration code that, when entered in the registration box, will remove the ‘nag’ screen. If 
you do not enter a registration code within the thirty-day period, the program will be 
terminated. 
 
Once you have purchased the product, it will be registered in your name and you will receive 
the latest version. As a registered user, you are allowed free unlimited ‘updates’ to the 
program. DameWare Mini Remote Control is licensed on a per user basis. 



 
There are several methods of registration and each are described on our web site as well as 
information on multi-user discount pricing and licensing. Please take a few minutes to fill out 
the Online Registration form on our web site so that we may obtain the necessary information 
to email you notifications of updates and new releases as they become available. You can 
find registration information along with this form on our web site at www.dameware.com. 
As with all programs, DameWare Mini Remote Control should be thoroughly tested with 
noncritical data before relying on it. The use of this program indicates that you have read and 
agree to these terms and that you assume all risks in the use of this program. 
 
7.3 Contact Information 
The staff at DameWare Development gratefully accepts all comments and suggestions. Many 
of our customers’ suggestions have been incorporated into this program to enhance its’ 
performance as well as its’ appearance. We appreciate the time taken to contact us with 
these comments as we strive to improve the level of quality and performance of our program. 
DameWare Development can be contacted anytime by email at support@dameware.com or 
by mail to the address below or by telephone. Our website serves as an online medium which 
can provide our customers with a number of resources to help resolve problems, report bugs 
and suggest improvements to our products or service. Our online FAQ contains valuable 
information and hints that may aid in resolving any issues that may arise. 
 
To contact DameWare Development: 
DameWare Development 
1024 Live Oak Loop 
Mandeville, La. 70448 
Phone: (504) 626-7545 
Fax: (504) 626-1189 
Information: dameware@dameware.com 
Sales: sales@dameware.com 
 
Technical Support: The staff at Optrics Inc. gratefully accepts all comments and suggestions. 
Many of our customers’ suggestions have been incorporated into this program to enhance its’ 
performance as well as its’ appearance. We appreciate the time taken to contact us with 
these comments as we strive to improve the level of quality and performance of our program. 
 
Optrics Inc. can be contacted anytime by email at info@Optrics.com or by mail to the address 
below or by telephone.  
To contact Optrics Inc.: 
Optrics Inc. 
Suite 100 4911 – 114 St. 
Edmonton, AB 
T6H 3L5 
 
www.Optrics.com 
Phone: 780-430-6240 
Fax: 780-432-5630 
 
Toll Free:  
  Canada: 1-877-463-7638 
 USA: 1-877-386-3763 



 
7.4 License Agreement 
DameWare Development License Agreement 
 
By installing or otherwise using this software, you accept all terms and conditions of this 
agreement. You furthermore agree that you may not modify, reverse engineer, decompile, 
disassemble, rent, lease or distribute any or all portions of this software. You may not copy 
this software except as specifically provided by this License Agreement. This is a legal 
agreement between you and DameWare Development for the product you have purchased, 
otherwise noted below as ‘the Software’. Should you not agree to the following terms, you 
may return the Software and documentation to the address below within 30 days from date of 
purchase for a refund less a restocking fee. 
 
DameWare Development, whose address is 1024 Live Oak Loop, Mandeville, Louisiana 
70448, USA, grants, with this license, the following rights. 
 
· Individual Use. You may purchase and install the Software as an individual on any single 
computer. You may also install a copy for your exclusive use on a home or portable 
computer. 
 
· Network/Storage Use. You may install the Software on a storage device or shared 
environment, such as a network server, however you must acquire a license for each 
individual using the Software. The Software may be used on different computers to the extent 
that the number of users does not exceed the specific number of licenses obtained from 
DameWare Development. If the Software is installed on a network/shared environment, you 
agree to provide technical or procedural methods to prevent the use of the Software by a 
greater number of individuals than specifically licensed. 
 
· Transfer. You may transfer the Software to a single recipient on a permanent basis provided 
you do not retain any copies (including archival or backup) and the recipient agrees to the 
terms and conditions of this Agreement. 
 
· Year 2000 Compliance. DameWare Development guarantees its products to be compatible 
with dates and times in reference to the 21st century. However, the underlying operating 
system must also support these dates and times to guarantee compliance. 
 
· Title. Title, ownership rights and intellectual property rights in and to the Software and 
documentation shall remain with DameWare Development. The copyright laws of the United 
States and international copyright treaties protect the Software and documentation. 
 
· Government Use. The Software and any documentation, with respect to acquisition by the 
United States Government, is classified as ‘commercial computer software’ as such terms are 
used in 48 C.F.R. 12.212 (Sept. 1995). The Software is supplied to the U. S. Government as 
a commercial end item and is subject to the terms set forth in this Agreement. If the Software 
is supplied for use by the Department of Defense, it is subject to the terms of this Agreement 
and in accordance with 48 C.F.R. 227.7202-1 through 227.7202-4 (June 1995), as 
applicable. 
 
· Limits of Warranty and Liability. DameWare Development warrants that the media supplied 
by DameWare Development containing the Software, will be free from defects in material and 



workmanship within 90 days from acquisition of the Software or DameWare Development will 
replace the defective media.  
 
THIS LIMITED WARRANTY IS THE ONLY WARRANTY MADE BY DAMEWARE 
DEVELOPMENT. DAMEWARE DEVELOPMENT MAKES NO OTHER WARRANTY, 
REPRESENTATION, OR CONDITION, EXPRESSED OR IMPLIED OF MERCHANTABILITY 
AND FITNESS FOR A PARTICULAR PURPOSE. SOME JURISDICTIONS DO NOT ALLOW 
LIMITATIONS ON HOW LONG AN IMPLIED WARRANTY OR CONDITION LASTS SO 
LICENSEE MAY HAVE OTHER LEGAL RIGHTS, WHICH VARY FROM STATE TO STATE. 
LICENSEE ASSUMES THE ENTIRE RISK AS TO THE RESULTS AND PERFORMANCE 
OF THE SOFTWARE AND UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL 
CONTRACT, THEORY OR OTHERWISE, SHALL DAMEWARE DEVELOPMENT OR ITS 
RESELLERS BE LIABLE TO LICENSEE OR ANY OTHER PERSON FOR ANY DAMAGES 
WHETHER INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL INCLUDING, 
WITHOUT LIMITATION, DAMAGES FOR LOSS OF USE, DATA, WORK STOPPAGE, 
COMPUTER FAILURE OR MALFUNCTION OR ANY AND ALL OTHER COMMERCIAL 
DAMAGES OR LOSSES, OR FOR ANY DAMAGES IN EXCESS OF DAMEWARE 
DEVELOPMENT’S LIST PRICE FOR A LICENSE OF THE SOFTWARE AND 
DOCUMENTATION. SOME STATES DO NOT ALLOW THE LIMITATION OR EXCLUSION 
OF LIABILITY FOR INCIDENTIAL OR CONSEQUENTIAL DAMAGES, SO THE ABOVE 
LIMITATION OR EXCLUSION MAY NOT APPLY TO LICENSEE. 
 
· Termination. This license is in effect until terminated. Failure to comply with the limitations 
set forth in this Agreement shall result in automatic termination of this license. In the case of 
termination, Licensee will return the Software and documentation to DameWare Development 
and will certify in writing that all copies of the Software have been returned or erased from the 
memory of its computers. 
 
· Miscellaneous. This Agreement represents the complete license agreement between the 
parties and supersedes any prior agreements between them. In the event that any provision 
of this Agreement should be deemed invalid or held to be unenforceable by any court of 
competent jurisdiction, that provision shall be enforced to the maximum extent permissible 
and the remainder of this Agreement shall remain in full force. This Agreement shall be 
governed by and construed under Louisiana law as such law applies to agreements between 
Louisiana residents entered into and to be performed within Louisiana, except as governed 
by Federal common law. 


